1. Home
  2. Knowledge Base
  3. General
  4. Pre-Sales
  5. Is the plugin multisite compatible?

Is the plugin multisite compatible?

All our plugins are multisite compatible.

How many site licenses do I need for a multisite?

To use one of our plugins on a WordPress multisite, you will need a license for each sub-site where you will be using it. For example:

  • If you want to use it on 5 sites in a multisite then you will need a license for 5 sites.
  • If your multisite contains 10 sites but you only want to use the plugin on 1 site, you will need a single site license.

You should enter the license key on the plugin settings page for each site where you want to use the plugin.

Do I need to network activate the plugin?

Yes, the plugin should be network activated even if you are only using it on 1 site within the multisite. This is needed in order to update the plugin.

Can I upgrade my existing license?

Yes, you can upgrade your license and just pay the difference. Please see our article on upgrading your license key.

Was this article helpful?

Related Articles