1. Knowledge Base
  2. WooCommerce Product Table
  3. Troubleshooting

PHP 7 Compatibility

All of our plugins are fully compatible with PHP7.

Some customers have reported that certain PHP compatibility checkers are flagging up problems in our plugins, usually related to the use of the “/e” modifier in the preg_replace function. For example, you might see an error like this:

FOUND 1 ERROR AFFECTING 1 LINE
————————————————————————————————————-
ERROR | preg_replace() – /e modifier is deprecated since PHP 5.5 and removed since PHP 7.0

You can safely ignore these messages.

These are false positives flagged up by the compatibility checker. We do use the preg_replace() function in some of our plugins but we don’t use the “/e” modifier. The checker isn’t able to correctly distinguish between different uses of the function, and flags up all instances of preg_replace, whether they use “/e” or not.

Still need help?
If searching the knowledge base hasn't answered your question, please contact support.

Related Articles